类别:Weakcurrent / 日期:2020-04-28 / 浏览:153 / 评论:0

我封装系统的时候是用的7zSfxTool打包的自解压文件,使用过程中出现了一个"不支持的算法"的问题,谷歌了一下说是算法过新的问题,可能默认用的是LZMA2,回到虚拟机的时候发现默认是LZMA是支持的算法,这就有点丈二的和尚摸不着头脑了。

解决7zSfxTool

期间我尝试过把7z降级,都无法解决这个问题,最后是通过更新文件的方式解决的,具体方法如下

1、首先打包文件为7Z,默认选择LZMA算法
2、随便找个小文件更新进压缩包内
3、删除压缩包内原打包文件(保留更新的文件)
4、重新将需要打包的文件以更新的方式存放进去,删除刚刚用来保留的临时小文件。

完成上面步骤你在用7zSfxTool创建自解压文件的时候,就不会在提示"不支持的算法"。

赞助

感谢您的打赏~

打开支付宝扫一扫,即可进行扫码打赏哦~

版权声明 : 本文使用「署名-相同方式共享 4.0 国际」创作共享协议,转载或使用请遵守署名协议 / Article Use Creative Commons Attribution-ShareAlike 4.0 International License「CC BY 4.0」
伤心叹戈

评论区

发表评论 / 取消回复

必填

选填

选填

◎欢迎讨论,请在这里发表您的看法及观点。

近期评论